PirateBox DIY – OpenWrt

Update May 30, 2014!

PirateBox 1.0 has been released and building or upgrading a PirateBox has never been easier! Please refer to this tutorial for instructions and more info. For support, be sure to visit the new PirateBox Forum.

Outdated Instructions Below!

You can build a PirateBox for as little as US$35. Be sure to check out the PirateBox forum for more info and support. And you can read more about the PirateBox project here and here.

piratebox5

Stuff You’ll Need

  • TP-Link MR3020 (Newegg) or TP-Link TL-WR703N (DX) (eBay)
  • USB Flash Drive (formatted FAT32 with a single partition)
  • Ethernet cable
  • 5V/USB Battery (optional)

Pre-Installation

The following tutorial was created on a Mac running OSX 10.8. However, these instructions will also work for Linux or Windows (requires PuTTY).

1. First download a custom copy of OpenWrt for the MR3020 (modified by Matthias Strubel to include all needed kernel-modules). See this thread on the forum for more info. NOTE: The 12.09 OpenWrt firmware has been reported to not work! See see this OpenWrt discussion thread before proceeding. For the WR703N, download this OpenWrt firmware

2. Set the toggle switch located beside the LAN/WAN port to WISP mode

3. Turn off your laptop’s wireless (in OSX, click on the wifi icon and select “Turn Wi-Fi Off”)

4. Connect the router via ethernet cable to your computer and open a web browser to http://192.168.0.254 (for the MR3020) or http://192.168.1.1 (for the WR703N)

5. Enter the default username & password (admin & admin)

6. Navigate to System Tools > Firmware Upgrade and select the OpenWRT firmware

(Note: The WR703N firmware text is in Chinese. To flash OpenWrt from the web interface, select the last menu item on the left, and then the third submenu item. More info in this Village Telco post).

7. After the upgrade completes, the system will restart

8. Telnet to the device:

telnet 192.168.1.1

9. Use the passwd command to set your login password – this will enable SSH:

passwd

10. Edit the network file with vi (vi cheat sheet):

NOTE: The following instructions assume your gateway router’s (home router’s) IP address is 192.168.2.1. If your gateway router differs from this, you will need to modify your network file accordingly. Keep in mind that your OpenWrt (PirateBox) router should not have the same address as your gateway router though it will need to be on the same subnet in order to access and download files from the Internet.

vi /etc/config/network

The modified file should look like this:

config interface 'loopback'                                                               
        option ifname 'lo'                                                                
        option proto 'static'                                                             
        option ipaddr '127.0.0.1'                                                         
        option netmask '255.0.0.0'                                                        

config interface 'lan'                                                                    
        option ifname 'eth0'                                                              
        option type 'bridge'                                                              
        option proto 'static'                                                             
        option ipaddr '192.168.2.111'                                                       
        option netmask '255.255.255.0'                                                    
        option gateway '192.168.2.1'                                                     
        list dns '192.168.2.1'                                                           
        list dns '8.8.8.8'

11. Remove the power from the router.

12. Turn ON your laptop’s wireless (for OSX, click on the wifi icon and select “Turn Wi-Fi On”)

13. Connect the MR3020 (or WR703N) to your gateway router (e.g. your home network router) with an ethernet cable and plug the power back in. Wait a couple of minutes until the router boots up. With your computer connected to your home network, try sshing into the router (Note: use the “ipaddr” you assigned in step 9):

ssh root@192.168.2.111

14. Ping google to ensure your firewall settings are correct:

ping google.com

15. Add USB support to OpenWrt by installing and enabling the following packages (Note: this step is not required if you used the customized OpenWrt image from step 1):

opkg update
opkg install kmod-usb-uhci
insmod usbcore ## may return: file exists
insmod uhci
opkg install kmod-usb-ohci ## may return: up to date.
insmod usb-ohci

Install PirateBox

Next you’ll need to install PirateBox on the router.

1. Connect your USB drive (formatted to FAT32 with only one partition) to the USB port.

2. Install the mkPirateBox package by issuing the following commands.

cd /tmp
opkg update && opkg install http://piratebox.aod-rpg.de/piratebox_0.6.3_all.ipk

3. Optional: Install the Kareha Image Board:

/opt/piratebox/bin/timesave.sh /opt/piratebox/conf/piratebox.conf install
/opt/piratebox/bin/install_piratebox.sh
/opt/piratebox/conf/piratebox.conf imageboard

Afterwards, edit the Kareha image board config file to change the admin username and password (ADMIN_PASS and SECRET):

vi /opt/piratebox/www/board/config.pl

4. Once the install is completed, unplug the ethernet cable and disconnect the power for at least 10 seconds.

5. Restart the device and join the “PirateBox – Share Freely” network. Open any web page and you should be redirected to the PirateBox menu.

6. Begin sharing files and chatting!

Upgrading

To upgrade from an earlier version of PirateBox, check out this tutorial on the PirateBox forum.

Recovery

For the TL-WR703N, use these instructions from the OpenWrt wiki to enter failsafe mode. See also Matthias Strubel’s video demo.

More info about building a serial port (useful for recovering a “bricked” router) for the TL-WR703N on TheVillageTelco wiki.

PirateBox Forum

Please post your questions, discoveries, ideas, and solutions in the PirateBox Forum.

Also read...

Comments

  1. Pingback: Online activist, programmer Swartz dies in N.Y. - ALIPAC

  2. Pingback: bigOfeature » Blog Archive » WE ARE ALL AARON SWARTZ

  3. Pingback: Enlaces compartidos

  4. Pingback: ¿La página de aterrizaje de tu PirateBox en tu idioma?

  5. Pingback: Gemischtwarenladen #4 « jfml/blog – illustration, design etc.

  6. Pingback: Un réseau alternatif à Internet voit le jour | Blogue

  7. Pingback: PirateBox by David Darts

  8. Pingback: Apollo-NG - Argus

  9. Pingback: Sneakernets and Un-clouding your files | No Fun Robot and Pandabrarian Explore Libraries

  10. Pingback: « Pirate box »: un réseau alternatif à Internet voit le jour à Clermont-Ferrand | ELISHEAN

  11. Pingback: PirateBox DIY – OpenWrt by David Darts

  12. Pingback: Bau die bubble | Pearltrees

  13. Pingback: Piratebox : partager ses fichiers avec son entourage sans Internet

  14. Pingback: Distributed Networking | Pearltrees

  15. Pingback: PirateBox usa Raspberry Pi para Compartilhar Arquivos e criar Chat Anônimo | Raspberry Pi Brasil

  16. Pingback: my 2013 bcla conference experience | librarianaut

  17. Pingback: Cheap wireless hacking with OpenWRT | Tap5

  18. Pingback: Halk Hareketlerinde Bilişim Teknolojisinin Kullanımı Üzerine Notlar | İbrahim Filazi Kişisel Web Sitesi

  19. Pingback: Piratebox – some notes | merglindev

  20. Pingback: LEDfirefly | Digital Electronics & DIY | Sc...

  21. Pingback: LEDfirefly | RaspberryPI | Scoop.it

  22. Pingback: PirateBox DIY - OpenWrt | morezane | Scoop.it

  23. Pingback: LED Fireflies are the new LED Throwie - Hackalizer

  24. Pingback: Is the Next Direction of Online Education…Offline? « Saylor.org – Free Online Courses Built by Professors

  25. Pingback: PiratenBox Teil2 | Notizen

  26. Pingback: Atlantide Box | litteraturing

  27. Pingback: Cheap alternative to WIFI USB Dongle for Sony Bravia | My two cents

  28. Pingback: PirateBox – some tipps | cd /home/ && cal

  29. Pingback: PirateBox – some tipps | cd /home/ && cal

  30. Pingback: John McAfee takes on the NSA with secure anonymity device | NEWS ONLINE

  31. Pingback: John McAfee takes on the NSA with secure anonymity device

  32. Pingback: John McAfee takes on the NSA with secure anonymity device «

  33. Pingback: Yebaa.com | John McAfee takes on the NSA with secure anonymity device

  34. Pingback: rushengine.com | John McAfee takes on the NSA with secure anonymity device

  35. Pingback: John McAfee takes on the NSA with secure anonymity device | Eric Hazelton

  36. Pingback: John McAfee takes on the NSA with secure anonymity device

  37. Pingback: Wie kann die Piratebox unter OpenWrt auf einem TP-Link TL-WR703N Router installiert werden? | Wenzlaff.de: Rund um die Programmierung

  38. Pingback: John McAfee takes on the NSA with secure anonymity device | Tech gadgets help

  39. Pingback: John McAfee takes on the NSA with secure anonymity device | e-Trader | Free Classifiedse-Trader | Free Classifieds

  40. Pingback: Foiling spooks: Mr McAfee's little black box

  41. Pingback: Piratebox | commandlinepunk.org

  42. Pingback: your friendly neighbourhood wretched hive of scum & villainy – a presentation | librarianaut

  43. Pingback: geek up your life » Condividere files in pubblico con una PirateBox

  44. Pingback: The Piratebox | Malwarebytes Unpacked

  45. Pingback: Raspberry Pi | Pearltrees

  46. Pingback: PirateBox DIY | Gamer GeekGamer Geek

  47. Pingback: Pirate Box test | Gamer GeekGamer Geek

  48. Pingback: Connecting people in remote areas - with a Pi - Raspberry Pi Projects

  49. Pingback: Piratebox « NESIT Hackerspace

  50. Pingback: Condividiamo la conoscenza – costruiamo una BiblioBox | Michele Maffucci

  51. Pingback: Condividiamo la conoscenza – costruiamo una BiblioBox | Michele Maffucci

  52. Pingback: Luciole numérique | EIRL Marc Sibert Consulting & Dispositifs

  53. Pingback: Luciole numérique | EIRL Marc Sibert Consulting & Dispositifs

  54. Pingback: PirateBox, una caja para el que sabe que compartir no es robar | eulaliobe

  55. Pingback: « Pirate box »: un réseau alternatif à Internet voit le jour à Clermont-Ferrand

  56. Pingback: PirateBox DIY | Era digital | Scoop.it

  57. Pingback: LibraryBox 2.0 public beta ist draußen

  58. Pingback: LibraryBox Enters Public Beta, Offers a New Tool for Managing Your eBook Library on a Network - The Digital Reader

  59. Pingback: Gemischtwarenladen | jfml/blog – illustration, design etc.

  60. Pingback: The BibleBox Project

  61. Pingback: Piratebox, la caja que crea wifis en cualquier lugar | CompartirWIFI

  62. Pingback: Who connects to random WiFi hotspots? | Hotel Existence

  63. Pingback: Gemischtwarenladen | jfml/blog – illustration, design etc.

  64. Pingback: Dateien im lokalen Netzwerk teilen | jfml/blog – illustration, design etc.

  65. Pingback: Construisez votre partage de contenus pour tous supports « BOX » |

  66. Pingback: Nerdcore › Open Source, portable Filesharing-Network: PirateBox 1.0 Released

  67. Pingback: PirateBox 1.0, платформа для организации анонимного общения и обмена файлами | AllUNIX.ru — Всероссийский портал о UNIX-системах

  68. Pingback: Useful websites and informative articles – part 4

  69. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) - TecNoticiero

  70. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) | FantecnolFantecnol

  71. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) | Blog actuales.es

  72. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) | recolector.de {tecnologia}

  73. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) - Descubridores de Tecnologia, Motor y Actualidad

  74. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) | Android vs IphoneAndroid vs Iphone

  75. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) | ResumenTecnologico.com

  76. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) | Rioja Al Dia

  77. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) | TecnoAR Computacion

  78. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil | Yuiping Joa

  79. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) - Webeando - Tecnología, Periodismo digital

  80. Pingback: PirateBox 1.0: compartir y comunicarse de forma privada y segura nunca fue más fácil (y barato) - Desarrollo de flirtime :Desarrollo de flirtime

  81. Pingback: Why I Love the Internet | FeetForBrains

Leave a Reply